解决PD12中Kali2.0无法安装parallels tools问题

权限不够-错误

在安装好kali后,需要安装pd-tools才能够和mac本机无缝配合,增加复制粘贴的体验,但是点进去是无法安装的。
显示权限不够.

验证发现在2017.01版本会出现权限不够的问题,需要把cdrom的文件复制到本地修改权限才可以完成。

1
2
3
4
5
6
7
8
9
10
11
12
13
# 取消挂载
sudo umount /media/cdrom0
# 重新挂载
sudo mount -o exec /media/cdrom0
# 复制到本地目录并更改权限
mkdir /tmp/1
sudo cp /media/cdrom0 /tmp/1
sudo chmod -R 777 /tmp/1
# 运行install_gui进行安装
cd /tmp/1
sudo ./install_gui

无法安装-错误

如果无法安装,可以在目录里面使用sudo ./install通过命令行安装,来看看爆出什么错误。
如果错误是无法安装下列软件

  • linux-headers-x.x.x-kali-xxxxx
  • dkms
  • kpartx
  • printer-driver-postscript-hp

则需要先添加一些国内的镜像源,然后更新一下系统的软件版本:

添加源

vim /etc/apt/sources.list
手动添加Kali 2.0 的源:

1
2
3
#中科大
deb http://mirrors.ustc.edu.cn/kali kali-rolling main non-free contrib
deb-src http://mirrors.ustc.edu.cn/kali kali-rolling main non-free contrib

使用阿里云发现会无法更新源。
#阿里云
deb http://mirrors.aliyun.com/kali kali-rolling main non-free contrib
deb-src http://mirrors.aliyun.com/kali kali-rolling main non-free contrib
deb http://mirrors.aliyun.com/kali-security kali-rolling/updates main contrib non-free

更新软件版本

在终端中使用更新目录:

1
2
3
apt-get update && apt-get upgrade
apt-get dist-upgrade
apt-get clean

运行文件

在终端中运行GUI安装:

1
sudo ./install_gui

安装完毕后重启即可。

Fontconfig-错误

如果出现Fontconfig error或者Fontconfig warning,目前本人没有找到解决方案,最好的方法是升级到PD12版本,不会出现这个错误。